Skip to main content

Java for Windows



         Thank you for using
Eclipse Installer


Unfortunately the Java version needed to run Eclipse Installer couldn't be found on your system. You need the following version or a higher version:

     Java 1.8.0 (64 Bit)


Please download and install a Java Runtime Environment (JRE), or a Java Development Kit (JDK) if you plan to do Java development

        Oracle JDK 12        Oracle JRE 12

Manual addition of --add-modules=ALL-SYSTEM required for applications based on Eclipse Neon (4.7) or older.

        Oracle JDK 11        Oracle JRE 11

Manual addition of --add-modules=ALL-SYSTEM required for applications based on Eclipse Neon (4.7) or older.

        Oracle JDK 10        Oracle JRE 10

Manual addition of --add-modules=ALL-SYSTEM required for applications based on Eclipse Neon (4.7) or older.

        Oracle JDK 9        Oracle JRE 9

Manual addition of --add-modules=ALL-SYSTEM required for applications based on Eclipse Neon (4.7) or older.

        Oracle JDK 8        Oracle JRE 8

The best default choice that is most compatible with all current and older Eclipse products.


Back to the top