Build: S-0.7.0M2-20100317233124 Incubation
March 17, 2010

The Eclipse Web Tools Platform (WTP) Incubator Project provides tools for development that are just getting started, or are experimental in some fashion.

All-in-one Packages

For most uses, we recommend web-developers download the "all-in-one" package, Eclipse IDE for Java EE Developers, from the main Eclipse download site.

Prerequisites and Handy Extras

These are the prerequisites to build or run these packages. All are not necessarily required, but instead some subset. Also listed are some frequently needed links for committer-required packages when creating new development environments, or targets to run against.

Note that WTP requires Java 5 or higher (and, for some things, actually requires a JDK rather than only a JRE) even though many other Eclipse Projects can run with other JRE levels.

Eclipse SDK (Platform, JDT)eclipse-SDK-3.5.2-win32.zip or appropriate platform or equivalent
EMF v2.5 Runtime Minimum executable code.emf-runtime-2.5.0.zip or equivalent
EMF XSD v2.5 Runtime Minimum executable code.xsd-runtime-2.5.0.zip or equivalent
@getName@ GEF Code and Source.GEF-SDK-3.5.2.zip or equivalent
WST WSTwtp-wst-sdk-R-3.1.2-20100211202452.zip or equivalent
DLTK SDK 1.0.2  DLTK Code and Source.dltk-core-sdk-S-1.0.2-201002091326.zip or equivalent

EMF v2.5 Source and Docs Additional download with Source and Documentation. emf-sourcedoc-2.5.0.zip or equivalent
EMF XSD v2.5 Source and Docs Additional download with Source and Documentation. xsd-sourcedoc-2.5.0.zip or equivalent
Eclipse Test Framework (required only for Automated JUnit tests) eclipse-test-framework-3.5.2.zip or equivalent
Eclipse releng tool (required only for committers to more easily "release" code to a build) org.eclipse.releng.tools-3.5.2.zip or equivalent
Third Party code from Orbit. Not required and is currently much more than needed for WTP, but some committers like using to create a PDE target. orbit-R20100114021427.zip or equivalent
P2 repositories in zipped format files.

These are archive versions of P2 repositories that can be downloaded and installed into a development environment or PDE target. Its is recommended to install, rather than to to unzip the traditional packages, since it is more informative of missing prerequites or conflicting dependencies.

Minimal

Executable code

xquery(3052K)
SDK

Executable code and source

xquery sdk(4958K)
Traditional Zip Files

The Zip files includes the features and plugins for XQuery Development Tools Note: These traditional zip files should be considered deprecated, in favor of using the archived P2 repositories. The tradtional zip files will one day disappear.

Minimal

Executable code only.

xquery(3044K)[md5]
SDK

Executable code and source code.

xquery sdk(4957K)[md5]
Tests

Unit tests.

xquery tests(0M)[md5]
Status, tests and other interesting details
map files
Unit test results 0  Total: 0
Compile logs: Code Bundles  (19)  0 4 0 78 
Compile logs: Test Bundles  (0)  0 0 0 0 


All downloads are provided under the terms and conditions of the Eclipse.org Software User Agreement unless otherwise specified.

If you have problems downloading the drops, contact the webmaster.